Как сделать формулу в Excel

Программа Excel обладает практически безграничными возможностями, позволяя обрабатывать информацию в пару кликов. В частности, благодаря формулам автоматизируется весь процесс работы с числовыми данными – вычисления можно получить мгновенно. А при изменении исходных значений менять вручную ничего не приходится, поскольку формула автоматически делает перерасчет.

 

Работа с формулами

Excel – программируемый калькулятор, где можно без труда вычислить максимальные и минимальные значения, средние показатели, проценты и многое другое. Все расчеты выполняются с помощью специальных формул, но вписывать их нужно правильно, иначе результат будет некорректным.

Ввод

В первую очередь нужно активизировать любую ячейку, осуществив двойной клик по ней. Также можно использовать верхнюю строку. Ввод формулы обязательно начинается со знака «=», далее вписывается числовое значение и нажимается Enter. В выбранной ячейке отображается результат.

Программа понимает стандартные математические операторы:

  • сложение «+»;
  • вычитание «-»;
  • умножение «*»;
  • деление «/»;
  • степень «^»;
  • меньше «<»;
  • больше «>»;
  • меньше или равно «<=»;
  • больше или равно «>=»;
  • не равно «»;
  • процент «%».

Можно использовать числа, адреса ячеек и даже комбинировать их в одной формуле.

Если в одной формуле используется несколько разных математических операторов, Эксель обрабатывает их в математическом порядке:

  • «%» и «^»;
  • «*» и «/»;
  • «+» и «-».

Меняется последовательность математических действий и при помощи скобок – программа в первую очередь вычисляет значение в скобках.

Постоянные и абсолютные ссылки

По умолчанию в Экселе все ячейки относительные, а значит, могут изменяться при копировании. Абсолютные являются постоянными, то есть не могут изменяться при копировании, если не задано другое условие.

Относительные ссылки помогают «растянуть» одну формулу на любое количество столбцов и строк. Как это работает на практике:

  1. Создать таблицу с нужными данными.

  1. Чтобы найти общую стоимость за каждый товар, нужно количество единиц умножить на цену. Для этого в первую ячейку вписать формулу через знак «=» и нажать Enter.

  1. Те же манипуляции можно провести для каждого товара или же скопировать первую формулу и вставить ее в остальные ячейки по очереди. Но все делается проще: кликнуть на ячейку, в правом нижнем углу появится маркер заполнения, нажать на него и, не отпуская кнопку мышки, потянуть вниз.

Абсолютный адрес обозначается знаком «$». Форматы отличаются:

  1. Неизменна строка – A$1.
  2. Неизменен столбец – $A
  3. Неизменны строка и столбец – $A$1.

Работу абсолютной ссылки рассмотрим на примере расчета доли каждого товара в общей стоимости:

  1. Сначала посчитать общую стоимость. Это делается несколькими способами: обычным сложением всех значений или автосуммой (выделить столбец с одной пустой ячейкой и на вкладке «Главная» справа выбрать опцию «Сумма», либо вкладка «Формулы» – «Автосумма»).

  1. В отдельном столбце разделить стоимость первого товара на общую стоимость. При этом значение общей стоимости сделать абсолютным.

  1. Для получения результата в процентах можно произвести умножение на 100. Однако проще выделить ячейку и выбрать в разделе «Главная» формат в виде значка «%».

  1. С помощью маркера заполнения опустить формулу вниз. В итоге должно получиться 100%.

Виды формул

Excel понимает несколько сотен формул, которые проводят не только расчеты, но и другие операции. При правильном введении функции программа подсчитает возраст, дату и время, предоставит результат сравнения таблиц и т.д.

Простые

Здесь не придется долго разбираться, поскольку выполняются простые математические действия.

СУММ

Определяет сумму нескольких чисел. В скобках указывается каждая ячейка по отдельности или сразу весь диапазон.

=СУММ(значение1;значение2)

=СУММ(начало_диапазона:конец_диапазона)

ПРОИЗВЕД

Перемножает все числа в выделенном диапазоне.

= ПРОИЗВЕД(начало_диапазона:конец_диапазона)

ОКРУГЛ

Помогает произвести округление дробного числа в большую (ОКРУГЛВВЕРХ) или меньшую сторону (ОКРУГЛВНИЗ).

ВПР

Это – поиск необходимых данных в таблице или диапазоне по строкам. Рассмотрим функцию на примере поиска сотрудника из списка по коду.

Искомое значение – номер, который нужно найти, написать его в отдельной ячейке.

Таблица – диапазон, в котором будет осуществляться поиск.

Номер столбца – порядковый номер столбца, где будет осуществляться поиск.

Альтернативные функции – ИНДЕКС/ПОИСКПОЗ.

СЦЕПИТЬ/СЦЕП

Объединение содержимого нескольких ячеек.

=СЦЕПИТЬ(значение1;значение2) – цельный текст

=СЦЕПИТЬ(значение1;» «;значение2) – между словами пробел или знак препинания

КОРЕНЬ

Вычисление квадратного корня любого числа.

=КОРЕНЬ(ссылка_на_ячейку)

=КОРЕНЬ(число)

ПРОПИСН

Альтернатива Caps Lock для преобразования текста.

=ПРОПИСН(ссылка_на_ячейку_с_текстом)

=ПРОПИСН(«текст»)

СТРОЧН

Преобразует текст в нижний регистр.

=СТРОЧН(ссылка_на_ячейку_с_текстом)

= СТРОЧН(«текст»)

СЧЁТ

Подсчитывает количество ячеек с числами.

=СЧЁТ(диапазон_ячеек)

СЖПРОБЕЛЫ

Убирает лишние пробелы. Это будет полезно, когда данные переносятся в таблицу из другого источника.

=СЖПРОБЕЛЫ(адрес_ячейки)

Сложные

При масштабных расчетах часто возникают проблемы с написанием функций или ошибки уже в результате. В этом случае придется немного изучить функции.

Важно! Критерии обязательно нужно брать в кавычки.

ПСТР

Позволяет «достать» требуемое количество знаков из текста. Обычно используется при редактировании тайтлов в семантике.

=ПСТР(ссылка_на_ячейку_с_текстом;начальная_числовая_позиция;число_знаков_которое_вытащить)

ЕСЛИ

Анализирует выбранную ячейку и проверяет, отвечает ли значение заданным параметрам. Возможны два результата: если отвечает – истина, не отвечает – ложь.

=ЕСЛИ(какие_данные_проверяются;если_значение_отвечает_заданному_условию;если_значение_не_отвечает_заданному_условию)

СУММЕСЛИ

Суммирование чисел при определенном условии, то есть необходимо сложить не все значения, а только те, которые отвечают указанному критерию.

=СУММЕСЛИ(C2:C5;B2:B5;«90»)

Исходя из примера, программа посчитала суммы всех чисел, которые больше 10.

СУММЕСЛИМН

Суммирование чисел на основе нескольких заданных условий.

=СУММЕСЛИМН(диапазон_суммирования;диапазон_условия1;условие1;диапазон_условия2;условие2;…)

Программа посчитала общую сумму зарплат женщин-кассиров.

По такому же принципу работают функции СЧЁТЕСЛИ, СРЗНАЧЕСЛИ и т.п.

Комбинированные

Эксель обладает широкими возможностями, в частности, позволяет комбинировать функции любым способом.

Есть задача: найти сумму трех чисел и умножить ее на коэффициент 1,3, если она меньше 80, и на коэффициент 1,6 – если больше 80.

Решение следующее: =ЕСЛИ(СУММ(А2:С2)<80;СУММ(А2:С2)*1,3;СУММ(А2:С2)*1,6). Если сумма диапазона будет больше числа 80, программа посчитает условие СУММ(А21:С2)*1,3, если больше – СУММ(А21:С2)*1,6.

Комбинированные формулы могут включать 10 и более функций.

Встроенные

Необязательно запоминать все функции. В разделе «Формулы» слева на панели расположена опция «Вставить функцию» – там есть список всех известных функций с описанием и разделением по категориям для удобства.

Чтобы воспользоваться какой-либо функцией, нужно кликнуть по желаемой ячейке, нажать на значок указанной выше опции или посредством комбинации клавиш Shift+F3 вызвать диалоговое окно мастера. В списке найти функцию, клацнуть по ней, в открывшемся окне заполнить поля диапазона (чисел), критерия и выбрать условие.

Комментариев нет

Добавить комментарий

%d такие блоггеры, как: