Транк между Cisco и D-Link

В этой статье мы будем линковать свитч Сisco C3560E, выступающий в качестве core switch со свитчами Dlink DGS-3120 и DES-1210, выступающими в качестве access уровня. Соединение будет производиться 2мя проводами. Концепция работ на обоих устройсвах одинаковая — создаём виртуальный канал и добавляем в него интерфейсы, которые хотим агрегировать.

Настраиваем агрегацию

Cisco:

interface Port-channel1
description "Trunk to Dlink1"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk

interface GigabitEthernet0/3
description " Trunk to Dlink "
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active

interface GigabitEthernet0/15
description "Trunk to Dlink"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
channel-protocol lacp
channel-group 1 mode active

Как видите в транке я разрешаю хождение только vlan 1 — когда будет надо я добавлю другие. Тут просто смысл что я ограничиваю то, что будет идти на акцесс-свитчи.

Настроим D-Link. Агрегировать мы будет 21 и 22 порты

config link_aggregation algorithm mac_source_dest
create link_aggregation group_id 1 type lacp
config link_aggregation group_id 1 master_port 21 ports 21-22 state enable
config lacp_port 1-27 mode passive

Добавляем вланы

Теперь давайте рассмотрим как добавить влан. Допустим мы придумали vlan100 для управления — так называемая менеджмент сеть. Первым делом не забываем создать новые вланы, так как никаких протоколов для передачи вланов между коммутаторами мы не используем:

Cisco

(config)#vlan 100 name management

D-Link

create vlan management tag 100

Хождение вланов между устройствами

А теперь разрешим хождение этого влана между устройствами
На Cisco это делается только в Port-channel — изменения сами применяются ко всем портам, которые включены в этот канал

(config)#interface Port-channel1
(config-if)#switchport trunk allowed vlan 1,100

А на D-Link мы порты добавляем во вланы

config vlan management add tagged 21-22

Ссылки

https://mschedrin.wordpress.com/2008/04/17/link-aggregation-d-link-3326-and-cisco/

http://www.dlink.ru/ru/faq/62/250.html

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *